Views:

Check if your iPhone, iPad or iPod Touch meets the minimum requirements to run and install Trend Micro Mobile Security.

  • iOS 11.0 or higher
  • iPadOS 13.0 or higher
  • Internet Connection (to activate and check expiration date, to download app updates and antivirus database)

Ready to install?

Click here to start using the app.

System requirements for other devices