Views:

Release Date: November 17, 2017

Trend Micro Vulnerability Identifier: VRTS-1128

Platform: Windows OS

Summary

Trend Micro has released a new build of Trend Micro Encryption for Email. This build resolves a service DLL pre-loading vulnerability.

Affected version(s)

Trend Micro Encryption for Email version 5.6.0.1073 and below

Solution

Trend Micro has released a new build to address the issue:

Trend Micro Encryption for Email 5.9.0.1082

IMPORTANT:

This is the minimum version of the build required to address the issue. Trend Micro highly encourages customers to obtain the latest version of the product if there is a newer one available than the one listed above.

Customers are encouraged to visit Trend Micro’s Download Center to obtain the latest software before applying any of the solutions above.

Vulnerability Details

This new version of Trend Micro Encryption for Email resolves a service DLL pre-loading vulnerability that could allow an unauthenticated remote attacker to execute arbitrary code on a vulnerable system.

Customers are highly encouraged to update to the latest build as soon as possible.

Mitigating Factors

Exploiting these type of vulnerabilities generally require that an attacker has access to a vulnerable machine. In addition to timely application of patches and updated solutions, customers are also advised to review remote access to critical systems and ensure policies and perimeter security is up-to-date.

Even though an exploit may require several specific conditions to be met, Trend Micro bly encourages customers to update to the latest builds as soon as possible.

Acknowledgement

Trend Micro would like to thank Kushal Arvind Shah of Fortinet’s FortiGuard Labs for responsibly disclosing this issue and working with Trend Micro to help protect our customers.

Additional Assistance

Customers who have questions are encouraged to contact Trend Micro Technical Support for further assistance.

Related Info

Comments (0)
Add a comment